/ Code Analysis

Minimalistic library that helps to find outdated golang packages

Minimalistic library that helps to find outdated golang packages

go-outdated

Go-outdated is minimalistic library that helps to find outdated packages hosted on github.com in your golang project.

Installation

Install the library with:

go get -u github.com/firstrow/go-outdated

Usage

Note: To use this library without limitations, you should create GitHub access token.

cd $GOPATH/path/to/your/project
go-outdated

GitHub access token

GitHub API has requests limit. You should create access token and pass it to go-outdated

go-outdated -token=YOUR_PRIVATE_GITHUB_TOKEN

Re-entering API token

Yes, typing each time access token in command-line is not easy. Use git config to re-use token:

git config --global github.token YOUR_PRIVATE_GITHUB_TOKEN
go-outdated # token will be taken from git config

Github doc: https://github.com/blog/180-local-github-config

Aliases

If you for some reason do not want to configure you local git config, You can create command-line alias in your .zshrc or .bashrc files. Example:

alias go-outdated='go-outdated -token=YOUR_PRIVATE_GITHUB_TOKEN'

Todo

  • Cache
  • Refactor

GitHub