Terraform MCS Provider

Requirements

  • Terraform 1.0.x
  • Go 1.16 (to build the provider plugin)

Using The Provider

To use the provider, prepare configuration files based on examples from here

$ cd $GOPATH/src/github.com/MailRuCloudSolutions/terraform-provider-mcs/examples/create-mcs-cluster
$ vim provider.tf
$ terraform init
$ terraform plan

Provider development

$ mkdir -p $GOPATH/src/github.com/MailRuCloudSolutions
$ cd $GOPATH/src/github.com/MailRuCloudSolutions
$ git clone [email protected]:MailRuCloudSolutions/terraform-provider-mcs.git
$ cd $GOPATH/src/github.com/MailRuCloudSolutions/terraform-provider-mcs
$ make build
...
$ $GOPATH/bin/terraform-provider-mcs

Thank You

GitHub

https://github.com/MailRuCloudSolutions/terraform-provider-mcs